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1 Introduction 

This FLM Starter Guide is aimed towards a beginner designing his first form. Although it is 
helpful for you to be familiar with SAP and Adobe Designer, it should be possible for 
anyone to follow the step-by-step instructions given here and create your first FLM form 
and get a feel for the processes involved. 
 
The aims of this exercise are to: 

- Create a new form data definition using the FLM form wizard 
- Combine the data definition with the form template to create a working Interactive 

Form 
- Enter the required UserExit code to prepopulate, create a dropdown menu, and 

validate fields on the form 
- Launch the finished form in the FLM portal and test it. 

 
Exercise Prerequisites: 

- FLM installed on the system 
- Customer code initialised 
- Form Status, Action and Category codes created. 
- Message 996 set up 
- Message ‘Form submitted for approval’ set up e.g. as number 100 
- Users 1 and 2 configured 

 

2 Creating the Data Definition of a Form in SAPGUI 

The form data definition is done in the SAP IMG. 
 
 
 
Login to SAP with your username and password. 
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Go to transaction ‘spro’ by entering it in the transaction box and pressing return. 
 

 
 
 
 
Click on ‘SAP reference IMG’ 
 

 
 
 
 
Go to Cross-Application Components> General Application Functions> Forms Lifecycle 
Manager> Interactive Forms> Setup Forms> Form Wizard. 
 

 
 
 
The Form Wizard will open: 
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Enter a 4-character form character code, version number, language and form 
description. 
 

 
 
 
 
 
Click Continue, then launch the Form Data Designer. First, click on the ‘Subforms’ tab. 
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Begin by creating a subform in the region shown. Call it ‘subform_1’ with a MaxOccurs 
of 1 with ROOT as the parent. Click ‘add subform’ and it will appear in the table on the 
right. 
 

 
 
Repeat this process for two more subforms:  

rent: ROOT - subform_2 with MaxOccurs: 10 and Pa
- subform_3 with MaxOccurs: 1 and Parent: ROOT 

 
 the MaxOccurs facility allows you to set the maximum number of times items on a 

subform can be repeated using the + and – buttons on the form. 
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Your subform page should now look like this: 
 

 
 
 
Return to the ‘form fields’ tab to create your fields. 
 
 
 
 
The first field, for the sake of this example, will be called ‘prepop’, of type ‘numc’ and 
parent ‘subform_1’. Check the tickbox to ‘add prepopulation routine’. Finally click 
‘Add’ and it will appear in the field table. 
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Next, create two more fields, called ‘Dropdown_1’ and ‘Dropdown_2’, type: ‘CHAR’ 
and with parent: ‘Subform_2’. Check the box to add an F4 values routine to both. 
 

 
 
 
 
 
Finally, create a fourth field, called ‘validation’, type = NUMC and parent = subform_3. 
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Click on ‘Return to FLM Wizard’ in the bottom-left hand corner to exit the data 
designer. Click ‘Continue’. 
 

 
 
 
 
 
FLM automatically creates a directory on your computer in which to store the finished 
form file. Click ‘continue’. 
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We will be using the standard FLM template for this exercise, so click ‘Continue’ 
 

 
 
 
 
 
Select the following form options: Online transport, category FK4 (other). Click 
Continue. 
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Click ‘Continue’ to begin form code generation 
 

 
 
 
 
 
 

Click the  to complete the process 
 

 
 
 
 
 

This message will be displayed. Click the  to exit the wizard and return to the IMG 
menu. 
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3 Designing the layout in Adobe Designer 

 
Once the form’s data definition has been created, open your form template in Adobe 
Designer. It will be in the C:/FLM/Form Templates folder.  
 

 
 
 
 
 
The file will have the format: FLM _[3-digit customer code]_[4-digit form 
code]_E_[version number] 
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Go to File> New Data Connection 
 

 
 
 
 
 
Select ‘get data connection from XML schema’. Click Next. 
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Open the directory and select the FLM form. It will have a file name of 
FLM_FORM_DATA_[3-digit customer code]_[4-digit form code]_E_[version number] 
 

 
 
 
 
 
Click ‘Open’ 
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Check ‘embed XML schema’ and click ‘Finish’ 
 

 
 
 
 
 
Now the following appears in the ‘Data View’ tab next to the form hierarchy on the left 
hand side: 
 

 
 

 The Data View tab now contains the schema you defined in the FLM wizard. 
Subform_1 will correspond to the ‘Header’ field on the template, Subform_2 
corresponds to ‘Items’ and Subform_3 corresponds to ‘Footer’. ‘FLM_Action’ and 
‘FLM_Return’ are required by the system so are generated automatically. 
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The next step is to drag-and-drop the fields in the Data View onto the corresponding 
form fields. Do not drag-and-drop the subforms. 
 
Drag ‘Prepop’ onto the subform marked ‘Header Fields’ 
Drag ‘Dropdown_1’ and ‘Dropdown_2’ onto the ‘Item Fields’ subform 
Drag ‘Validation’ onto the ‘Footer Fields’ subform 
  

 
 

When the fields are successfully bound, the icon will appear next to that item in 
the Data View. 
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FLM_ACTION should be dragged and dropped onto the dropdown field next to the 
‘Send’ button. FLM_RETURN corresponds to the blank box on the left of the ACTION 
field as shown. 

FLM_ACTION should be dragged and dropped onto the dropdown field next to the 
‘Send’ button. FLM_RETURN corresponds to the blank box on the left of the ACTION 
field as shown. 
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You will need to create a drop-down chevron for both the dropdown fields on the form. 
 
To do this, select the required fields and click on the field type on the right-hand side. 
Select ‘drop down list’ from the options: 
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Click in the text boxes denoting the field names. Rename ‘Prepop’ to ‘Prepopulated’ 
and replace the underscores in the dropdown field names with spaces: 
 

 
 

 The names of the fields in the data view and in the FLM system do not change when 
you change the field descriptions on the form, so your field descriptions are not limited 
by the character and length restrictions in the data designer. It is advisable to keep the 
data designer names and field descriptions similar or have a system for field 
nomenclature when working with long forms. 
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In order to ensure that the form functions correctly, you will need to bind the 
subforms on the template to the subforms you created in the Form Wizard. 
In order to ensure that the form functions correctly, you will need to bind the 
subforms on the template to the subforms you created in the Form Wizard. 
  
To do this, return to the Hierarchy tab and under ‘DataFlow’, select the Header field.  To do this, return to the Hierarchy tab and under ‘DataFlow’, select the Header field.  
  

  
  
In the Object> Binding menu on the right, select the default binding to SUBFORM_1 by 

clicking on the  under the default binding and going to DataConnection> SUBFORM_1 
as shown. 

In the Object> Binding menu on the right, select the default binding to SUBFORM_1 by 

clicking on the  under the default binding and going to DataConnection> SUBFORM_1 
as shown. 
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Repeat the process for the ‘Items’ and ‘Footer’ subforms: 
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You should now have a form that looks like this: 
 

 
 

Save the form  and exit Adobe Designer. 
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4 Adding Business Logic 4 Adding Business Logic 

  
  
Return to SAP transaction SPRO IMG>Cross Application Components> General 
Application Functions> Forms Lifecycle Manager and go to ‘Upload Form Template’  
Return to SAP transaction SPRO IMG>Cross Application Components> General 
Application Functions> Forms Lifecycle Manager and go to ‘Upload Form Template’  
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Select the .XDP file you have just been working with. Click the ‘Execute’ icon on the 
top-left of the page. 
 

 
 
 
 
 
Confirm at the prompts: 
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Exit the menu using the  icon at the top of the page. 
 

 
 
 
 
 
Go into Field UserExits under business logic from the IMG menu: 
 

 
 
 
 
 
You will receive a prompt to enter the form type code you are working with. Enter 
‘EGF1’ and click ‘Continue’ 
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The screen shows a list of the fields that were assigned UserExits in the data designer, 
by category. To summarise:  
 
‘Dropdown_1’ and ‘Dropdown_2’ were assigned an F4 values routine 
‘Prepop’ was assigned a prepopulation routine 
‘Validation’ was assigned a validation routine. 
 
To edit the UserExit code that creates the dropdown options for ‘Dropdown_1’, select 
‘Dropdown 1’ from the list under the F4 tab and click on ‘F4 Possible Entries’ 
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The following screen will appear, containing the UserExit code behind the field 
‘Dropdown_1’. 
 

 
 
If you scroll down to the bottom of the page, there is a space denoted by  
<<<< Start of Customer code >>>> and <<<< End of Customer Code >>>> 
 
This is where you will enter the code to define the possible entries in the dropdown. 
Cut and paste the following code into the space: 
 
DATA: l_t005t     TYPE t005t, 
           l_form_data TYPE /flm/form_data. 
* 
  CLEAR ex_form_data. 
  SELECT * FROM t005t INTO l_t005t WHERE spras = sy-langu. 
* 
    CLEAR l_form_data. 
    l_form_data-name  = l_t005t-land1. 
    l_form_data-value = l_t005t-NATIO. 
 
    CHECK l_t005t-NATIO is not initial. 
 
    APPEND l_form_data TO ex_form_data. 
* 
  ENDSELECT.  
 

Click Activate  and then confirm. 
 

 This ABAP code will fill the dropdown menu with values from the table in SAP called 
t005t, excluding blank rows. Table t005t in this case contains a list of nationalities. 
This is a simple example, but you can enter any ABAP code here to use SAP’s resource 
to populate the dropdown options. 
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Select an appropriate location for the customising request, in this case ‘FLM Demo’s’ 
 

   
 

Exit the screen using the  icon. 
 
 
 
If you’re familiar with ABAP, you might like to try entering your own code into 
Dropdown 2 using the same method as dropdown 1. Otherwise, proceed to 
Prepopulation: 
 
Click on the PrePopulation tab, select the required field and then click the 

 button. 
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Enter the following code into the space denoted by  
<<<< Start of Customer code >>>> and <<<< End of Customer Code >>>>  
as before: 
 
ex_value = '12345'. 
 

 This code will prepopulate the field with the value ’12,345’. As with the F4 code, 
any ABAP code can be entered here to prepopulate the field. 
 

 
 

Click Save  and then confirm. Activate the code using the  tool as before and 

then exit . 
 
 
 

Enter the Validation tab, select the field and click on the  button. 
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Copy and paste the following code into the same space as before: 
 
IF <g_value> <= 100. 
      ex_mess_num = 996. 
      ex_msgvar1 =  'value must be greater than 100'. 
      ex_response = 'A'. 
    ENDIF. 
 

 This code will automatically validate the value entered into this field to ensure that 
it is over 100, and return an error message: ‘value must be greater than 100’ if this 
condition is not met. 
 

 
 

Click Save  and then confirm. Activate the code using the  tool as before and 

then exit . 
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5 Form Routing 

Here we will setup a simple routing for the form: 
 

 
 
This routing can be represented by a table of actions: 
 
User 
 

Form Status Action New User New Status 

Initial user  
(User 1) 

Initial Submit Approver 
(User 2) 

Submitted 

Approver 
(User2) 

Submitted Approve System 
 

Approved 

Approver 
(User 2) 

Submitted Reject Initial user 
(User 1) 

Rejected 

Initial user 
(User 1) 

Rejected Submit Approver 
(User 2) 

Submitted 

Initial user 
(User 1) 

Rejected Cancel System Cancelled 

 
To configure this workflow into FLM, first go into Form Status Determination from the 
IMG menu in Transaction SPRO: 
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Select the name of the form you are working with from the list and double-click on 
‘Workflow Status’ at the top-left of the screen: 
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From the second, third and fifth columns of the routing table above we can derive the 
following other actions: 
 
Submitted  Approve = End of life 
Submitted  Reject = Rejected 
Rejected  Submit = Submitted  
Rejected  Cancel = Cancelled 
 
Go to ‘New Entries’ and enter the above status processes into the table as shown 
below. When you have fininshed click the ‘Save’ icon to store the data. 
 

 This table can be used for more advanced routing configurations, e.g. email 
reminders and version variations, so it has a number of options that we won’t use for 
the sake of this example. 
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Next, go into ‘Form Owner Determination’ from the IMG menu: 
 

 
 
 
 
We will also need configure changes of user, as defined by the routing table: 
  
User 
 

Form Status Action New User New Status 

Initial user  
(User 1) 

Initial Submit Approver 
(User 2) 

Submitted 

Approver 
(User2) 

Submitted Approve System 
 

Approved 

Approver 
(User 2) 

Submitted Reject Initial user 
(User 1) 

Rejected 

Initial user 
(User 1) 

Rejected Submit Approver 
(User 2) 

Submitted 

Initial user 
(User 1) 

Rejected Cancel System Cancelled 
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Go into   to configure the form user routing by entering the information as 
follows. Click the Save icon to store. 
 

 
 

 ‘SYSTEM’ is not a configured user, however it is used here to transfer ownership of 
the form from the user who submitted it and hence remove it from their inbox. The 
form will be stored in the system without an ‘owner’, ready for any subsequent 
actions, such as data posting, to be applied to it. 
 
 
Click on the green tick to confirm. 
 

 
 

Exit the menu using the  icon at the top of the page. 
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6 Launching the form in the portal 

Launch the FLM portal in a browser using the URL:  
http://quattro:50100/webdynpro/dispatcher/flm.com/flmgui/flmportal 
 
   system host name http host 
 
Log in as the first user in the routing (USER1): 
 

 
 
 
 
Go to ‘Tasks’ and then ‘New Form’ 
 

 
 

http://quattro:50100/webdynpro/dispatcher/flm.com/flmgui/flmportal
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Click on the form category ‘FK4’ to which the form was assigned, scroll down through 
the list using the  button to form EGF1 and click on it. It will launch in the browser. 
 

 
 
 
 
When the form launches, the ‘Prepopulated’ field should contain the value ’12,345’, as 
determined by the UserExit code you entered. Clicking on the chevron next to 
‘Dropdown 1’ brings up the dropdown list you created, and you can increase the 
number of item fields on the form using the  button: 
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Test the validation code by entering a number less than 100 into the ‘Validation’ Field, 
selecting ‘Submit’ and clicking ‘send’ 
 

 
 
 
 
The error message you typed should appear: 
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Enter a valid number into the Validation field, select ‘Submit’ and click ‘Send’ again to 
send the form to the next user in the routing: 
Enter a valid number into the Validation field, select ‘Submit’ and click ‘Send’ again to 
send the form to the next user in the routing: 
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The form will be submitted, and a confirmation message will appear on the screen: 
 

 
 
 
 
If you have the login details of the next user in the routing, you can check that the 
form was routed successfully to them, as specified in the routing table. To do this, first 

, then enter the login details of the next user: 
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Go to Tasks> Inbox… 
 

 
 
 
 
… and the form you have just submitted (EGF1) should appear in the listing, with status 
‘Submitted’, created by USER1 with today’s date on it. Click on the form to open it. 
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The form will appear in the inbox of User 2 as it was when submitted by User 1. 
 

 It is possible to render the form’s fields to be read-only for an approver so that the 
contents of the fields are fixed at this stage of the routing. 
 
 

 
 

 User 2 doesn’t have the same transport options as User 1: these are defined by the 
Form Status Configuration you did in Section 5. 
 
You can decide whether to approve or reject the form. Rejecting it will return it to 
User 1; approving it will change its status to ‘Approved’, which can then be input as a 
valid status for posting to SAP by the Forms Posting Engine. 
 
 
 
 
Congratulations! You have just successfully created and tested your first FLM form. 
Please see the Configuration guide, the Developer Guide, the Form Design Guide and 
the System Administration Guide for more advanced instructions to configure a form 
and its processing to your requirements. 
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